$re = '/`(?P<class>\w+)>>(?P<method>(?:\w+):?(?:(?:(?:\w+):)+))`/';
$str = '`GHRequester>>blabla:blabl:`';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);