use strict;
my $str = 'a b c d e
a b "c d" e
a b \'c d\' e
a b "c d\' e';
my $regex = qr/([^\s"'\\]+)*("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)/p;
my $subst = '$1$2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";