import Foundation
let pattern = #"([^\s"'\\]+)*("[^"\\]*(?:\\.[^"\\]*)*"|'[^'\\]*(?:\\.[^'\\]*)*')*(\s+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a b c d e
a b "c d" e
a b 'c d' e
a b "c d' e
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)