use strict;
my $str = '\'example\' another_word';
my $regex = qr/\G((?:(?:"(?:\\[\S\s]|[^"\\])*"|'(?:\\[\S\s]|[^'\\])*')|[^"'\s]+)*)\s+/p;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";