re = /{{((?!contact\.firstName|contact\.lastName|contact\.phoneNumber|contact\.language)[^{}])*}}/
str = 'test {{debug}} {{contact.language}} test {{ {{ another word }} test {{test}} another {{contact.something}} {{contact.firstName}} {{contact.name}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end