re = /^(?:(?:[\s\w]*(?:({(?:[\s\w]*%\(\w*\)[\s\w]*)+(?:{(?:[\s\w]*%\(\w*\)[\s\w]*)+})*})+)[\s\w]*)+)$/m
str = '# Your valid example
abc {st1 %(ph1) st11} int {st2 %(ph2) st22}{st3 %(ph3) st33 {st31 %(ph4) st332}} cd
# Your valid Legenda
OptionalStaticText{OptionalStaticText %(Placeholder) OptionalStaticText {OptionalSubSection} OptionalStaticText} OptionalStaticText
# Your invalid example
abc {st1 %(ph1) st11} int {st2 %(ph2) st22}{st3 %(ph3) st33 {st31 %(ph4) st332}} c-d
# Without pre / post optional static text and some optional text inside section
{%(Placeholder) OptionalStaticText {OptionalSubSection}}
# With only a placeholder in the section
OptionalStaticText{%(Placeholder)} OptionalStaticText
# The valid version
abc {st1 %(ph1) st11} int {st2 %(ph2) st22}{st3 %(ph3) st33 {st31 %(ph4) st332}} cd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end