use strict;
my $str = 'First12word50 Secųond-Word Thirdųword \' result must be Secųond-Word
First1-2word50 Secųond/Word Thirdųword \' result must be Secųond/Word
First1/2word50 Secųond+Word Thirdųword \' result must be Secųond+Word
First1/2word50 Secųond1+Word Thirdų-word \' result must be Thirdų-word
First1/2word50 Sec1ųond1+Word Thir11dų-word';
my $regex = qr/^(?:(?=\S*\d)\S+(?:\s+(?=\S*\d)\S+)*\W*)?\K\S*/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}