# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?i:(?<!\S)([a-z]) +((?1))|\G(?!\A) +((?1))\b)/$1$2$3/gm;t' <<< "Welcome to the Greater S E A T T L E area"