package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s{0,}[Yy]\s{0,}`)
var str = `ynY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}