re = /^-?(?:0|[1-9]\d*)(?:_\d+)*(?:\.\d+(?:_\d+)*)?$/m
str = '1_2.3_4
1
-1
1.2
-1.2
0
0.00
0.1
000_00.00
0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end