$re = '/.*\b(?<![.,])(\d[\d.,]*)/';
$str = 'Sum of elements 1 - 4 is 16.4 total';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);