using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a[^>]*herf=''[^>]*>(.*?)<\/a>";
string substitution = @"$1";
string input = @"this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}