package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a[^>]*herf=''[^>]*>(.*?)<\/a>`)
var str = `this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a> this is a bet and he is <a herf=''>Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a herf=''>Yammy</a>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}