$re = '/<a[^>]*herf=\'\'[^>]*>(.*?)<\/a>/';
$str = 'this is a bet and he is <a herf=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a herf=\'\'>Yammy</a> this is a bet and he is <a herf=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a herf=\'\'>Yammy</a> this is a bet and he is <a herf=\'\'>Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a herf=\'\'>Yammy</a>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;