import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=A)\\{n\\}(?=(?:\\{n\\})*A)|\\G(?!^)\\{n\\}";
final String string = "{n}{n}A{n}{n}A{n}\n"
+ "{n}A{n}{n}{n}{n}A\n"
+ "{n}{n}A{n}A{n}{n}\n"
+ "{n}{n}{n}A{n}A{n}B\n"
+ "{n}A{n}{n}B{n}{n}\n"
+ "A{n}B{n}{n}{n}{n}";
final String subst = "C";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}