package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?P<Month>(?:01|02|03|04|05|06|07|08|09|10|11|1|2|1|2|3|4|5|6|7|8|9|Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec|January|February|March|April|May|June|July|August|September|October|November|December))[\-/\\\s]+(?P<Day>[0-3]?\d)[\-/\\\s]+(?P<Year>\d+)`)
var str = `1-2-1995`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}