// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(?P<Month>(?:01|02|03|04|05|06|07|08|09|10|11|1|2|1|2|3|4|5|6|7|8|9|Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec|January|February|March|April|May|June|July|August|September|October|November|December))[\-/\\\s]+(?P<Day>[0-3]?\d)[\-/\\\s]+(?P<Year>\d+)").unwrap();
let string = "1-2-1995";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}