#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "http:\/\/example\.com\/foo((\/[\w]+\b)?[^\/]|\/[^\w])"
Local $sString = "http://example.com/foo" & @CRLF & _
"http://example.com/foo/" & @CRLF & _
"http://example.com/foo/apple" & @CRLF & _
"http://example.com/foo/bear" & @CRLF & _
"http://example.com/foo/cake" & @CRLF & _
"" & @CRLF & _
"http://example.com/baa/apple" & @CRLF & _
"http://example.com/foo/apple/cake/bar/1" & @CRLF & _
"http://example.com/foo/bear/camel/bar/2" & @CRLF & _
"" & @CRLF & _
"http://example.com/foo/bear/cake/bar/two" & @CRLF & _
"http://example.com/foo/bear/camel/tar/2" & @CRLF & _
"http://example.com/foo/bear/camel" & @CRLF & _
"http://example.com/foo/bear/camel/" & @CRLF & _
"http://example.com/foo/bear/camel/tar/2/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")