package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/example\.com\/foo((\/[\w]+\b)?[^\/]|\/[^\w])`)
var str = `http://example.com/foo
http://example.com/foo/
http://example.com/foo/apple
http://example.com/foo/bear
http://example.com/foo/cake
http://example.com/baa/apple
http://example.com/foo/apple/cake/bar/1
http://example.com/foo/bear/camel/bar/2
http://example.com/foo/bear/cake/bar/two
http://example.com/foo/bear/camel/tar/2
http://example.com/foo/bear/camel
http://example.com/foo/bear/camel/
http://example.com/foo/bear/camel/tar/2/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}