$re = '/^(?!(?:^|.*,)([^,\n]*),.*\1(?:,|$)).*$/m';
$str = 'value1,value2,value2,va-lu4,value 6
value1,value2,value3,va-lu4,value 6,value1
value1,value2,value3,va-lu4,value 6
value1,value1,value8,va-lu4,value 6
value1,value2,value8,va-lu4,value 6
value1,value2,value3,va-lu4,value 6,value 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);