$re = '/^(?:(?:\w+(?:[_.-]\w+)*)|\$test\$)$/m';
$str = 'test
test-5
test.1.3
test-alpha.2
$test$
But not...
$test
test$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);