$re = '/[-+]?\d+(\.\d+)?/';
$str = '2.3434 -3434.22 +23.2323 2323';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);