using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,2}(\.\d{2})?$";
string substitution = @"\1_XXX";
string input = @"10
5
5.00
10.00
.25
10.1
10.255";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}