const regex = /^\d{1,2}(\.\d{2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,2}(\\.\\d{2})?$', 'gm')
const str = `10
5
5.00
10.00
.25
10.1
10.255`;
const subst = `\1_XXX`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);