# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d{1,2}(\.\d{2})?$"
test_str = ("10\n"
"5\n"
"5.00\n"
"10.00\n\n"
".25\n"
"10.1\n"
"10.255")
subst = "\\1_XXX"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.