using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\]\s*(?:\d+|[a-zA-Z]+)\.\s*";
string substitution = @"] ";
string input = @"[ 1.1 ] 1. A method of providing a master
[ 12.1 ] 12. An apparatus for providing
[ 39.3 ] b. one or more control point applications
[ 39.8 ] iv. a server application programming interface
[ 30.2 ] a. a client application programming
[ 1.2 ] an RFID device provided";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}