const regex = new RegExp('\\]\\s*(?:\\d+|[a-zA-Z]+)\\.\\s*', 'gm')
const str = `[ 1.1 ] 1. A method of providing a master
[ 12.1 ] 12. An apparatus for providing
[ 39.3 ] b. one or more control point applications
[ 39.8 ] iv. a server application programming interface
[ 30.2 ] a. a client application programming
[ 1.2 ] an RFID device provided`;
const subst = `] `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);