use strict;
my $str = '[ 1.1 ] 1. A method of providing a master
[ 12.1 ] 12. An apparatus for providing
[ 39.3 ] b. one or more control point applications
[ 39.8 ] iv. a server application programming interface
[ 30.2 ] a. a client application programming
[ 1.2 ] an RFID device provided';
my $regex = qr/\]\s*(?:\d+|[a-zA-Z]+)\.\s*/mp;
my $subst = '] ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";