import Foundation
let pattern = #"\]\s*(?:\d+|[a-zA-Z]+)\.\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ 1.1 ] 1. A method of providing a master
[ 12.1 ] 12. An apparatus for providing
[ 39.3 ] b. one or more control point applications
[ 39.8 ] iv. a server application programming interface
[ 30.2 ] a. a client application programming
[ 1.2 ] an RFID device provided
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"] "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)