re = /([A-Z]+)/m
str = '\'coordinatorCountry\': \'coordinator_country\',
\'ecContribution\': \'ec_contribution\',
\'ecMaxContribution\': \'ec_max_contribution\',
\'endDate\': \'end_date\',
\'frameworkProgramme\': \'framework_programme\',
\'fundingScheme\': \'funding_scheme\',
\'participantCountries\': \'participant_countries\',
\'projectUrl\': \'project_url\',
\'startDate\': \'start_date\',
\'totalCost\': \'total_cost\',
\'activityType\': \'activity_type\',
\'ecCContribution\': \'ec_contribution\',
\'endOfParticipation\': \'end_of_participation\',
\'organizationUrl\': \'organization_url\',
\'postCode\': \'post_code\',
\'shortName\': \'short_name\',
\'vatNumber\': \'vat_number\',
\'projectID\': \'project_id\','
subst = '_\\L$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result