#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Ingredients\R((?>(?!Ingredients$).*\R)+?)Preparation$"
Local $sString = "Recipes & Menus" & @CRLF & _
"Expert Advice" & @CRLF & _
"Ingredients" & @CRLF & _
"Holidays & Events" & @CRLF & _
"Community" & @CRLF & _
"Video" & @CRLF & _
"SUMMER COOKING" & @CRLF & _
"Lentil and Brown Rice Soup" & @CRLF & _
"Gourmet January 1991" & @CRLF & _
"3.5/4" & @CRLF & _
"reviews (83)" & @CRLF & _
"90%" & @CRLF & _
"make it again" & @CRLF & _
"Some soups genuinely do inspire a devotion akin to love, and this is one of" & @CRLF & _
"them. In the cold of winter, when Gourmet editors ponder the matter of what soup" & @CRLF & _
"Cook" & @CRLF & _
"Reviews (83)" & @CRLF & _
"YIELD: Makes about 14 cups, serving 6 to 8" & @CRLF & _
"Ingredients" & @CRLF & _
"5 cups chicken broth" & @CRLF & _
"1 1/2 cups lentils, picked over and rinsed" & @CRLF & _
"1 cup brown rice" & @CRLF & _
"a 32- to 35-ounce can tomatoes, drained, reserving the juice, and chopped" & @CRLF & _
"3 carrots, halved lengthwise and cut crosswise into 1/4-inch pieces" & @CRLF & _
"1 onion, chopped" & @CRLF & _
"1 stalk of celery, chopped" & @CRLF & _
"3 garlic cloves, minced" & @CRLF & _
"1/2 teaspoon crumbled dried basil" & @CRLF & _
"1/2 teaspoon crumbled dried orégano" & @CRLF & _
"1/4 teaspoon crumbled dried thyme" & @CRLF & _
"1 bay leaf" & @CRLF & _
"1/2 cup minced fresh parsley leaves" & @CRLF & _
"2 tablespoons cider vinegar, or to taste" & @CRLF & _
"Preparation" & @CRLF & _
"In a heavy kettle combine the broth, 3 cups water, the lentils, the rice, the tomatoes with the reserved juice,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")