import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "jest.mock\\(\\s*\\\"(?:\\.\\./){4}src/components/(?P<name>\\S+)\\\",\\s*\\(\\) => \\\"(?P=name)\\\"\\s*\\);";
final String string = "// BEEP BOOP! I am a generated file. Don't edit me manually.\n"
+ "// @flow\n\n"
+ "import initStoryshots from \"@storybook/addon-storyshots\";\n"
+ "jest.mock(\n"
+ " \"../../../../src/components/BorderlessButton\",\n"
+ " () => \"BorderlessButton\"\n"
+ ");\n"
+ "jest.mock(\"../../../../src/components/BorderlessButton\", () => \"BorderlessButton\");\n\n\n"
+ "initStoryshots({\n"
+ " storyKindRegex: /^IconButton$/\n"
+ "});\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}