const regex = new RegExp('jest.mock\\(\\s*\\"(?:\\.\\./){4}src/components/(?P<name>\\S+)\\",\\s*\\(\\) => \\"(?P=name)\\"\\s*\\);', 'g')
const str = `// BEEP BOOP! I am a generated file. Don't edit me manually.
// @flow
import initStoryshots from "@storybook/addon-storyshots";
jest.mock(
"../../../../src/components/BorderlessButton",
() => "BorderlessButton"
);
jest.mock("../../../../src/components/BorderlessButton", () => "BorderlessButton");
initStoryshots({
storyKindRegex: /^IconButton\$/
});
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}