#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\(File Attachment:\s(.*)?\)[\r\n]?"
Local $sString = "dsfasdljkfjalkf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(File Attachment: /home/username/public_html/someFile.pdf)" & @CRLF & _
"(File Attachment: /home/username/public_html/someFile.pdf)" & @CRLF & _
"(File Attachment: /home/username/public_html/someFile.pdf)" & @CRLF & _
"(File Attachment: /home/username/public_html/someFile.pdf)" & @CRLF & _
"dfsdfdsf" & @CRLF & _
"dsfdsfdsf" & @CRLF & _
"" & @CRLF & _
"sdfdsfdsf" & @CRLF & _
"sdf"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)