// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(File Attachment:\s(.*)?\)[\r\n]?").unwrap();
let string = "dsfasdljkfjalkf
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
(File Attachment: /home/username/public_html/someFile.pdf)
dfsdfdsf
dsfdsfdsf
sdfdsfdsf
sdf";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}