$re = '/(?:\"[^\"]*\")|(})/';
$str = 'if (true){var data = string.Format(\\"something {0} {1}.\\", \\"is\\", \\"wrong\\");}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);