use strict;
my $str = 'mmholAhsbC123*';
my $regex = qr/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%/()=¿?*+-])(?=(?:([\w\d])\1?(?!\1\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$/p;
my $subst = 'VALID PASSWORD';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";