use strict;
my $str = '
This is a test of the agenda and objectives format
This shouldn’t get picked up
Dasdasdasd d asda sd : asd obe: sad neither shood this
Objective: This is how the object should look, this is a long one
Agenda:
1.
Make like a tree
2.
And
3.
Get out of here
Some more stuff here, and here and ::: ;s
Sadfdsf sdfdfeswrfew ';
my $regex = qr/^(\d+\.)\s+([^\r\n]+)(?:[\r\n]*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}