using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?=.{0,10}\))([^)]+)\)";
string input = @"(some text) some other text -> some text
(some) some other text -> some
(12345) some other text -> 12345
(TooLongStri) -> nothing matched because 11 characters";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}