#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(--.*$|\/\*[\s\S]*?\*\/)"
Local $sString = "-- fdf" & @CRLF & _
"fdf" & @CRLF & _
"sdfdsf /* fsdf /* */ other /* */ sdfsdf" & @CRLF & _
"isdf -- sdf" & @CRLF & _
"/* fd */" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
"" & @CRLF & _
"multiline" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"more here" & @CRLF & _
"" & @CRLF & _
"/* dangling" & @CRLF & _
"" & @CRLF & _
"-- ${here} more ${another} blah" & @CRLF & _
"" & @CRLF & _
"/* ${you} */ ${yeah}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")