using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(--.*$|\/\*[\s\S]*?\*\/)";
string input = @"-- fdf
fdf
sdfdsf /* fsdf /* */ other /* */ sdfsdf
isdf -- sdf
/* fd */
/*
multiline
*/
more here
/* dangling
-- ${here} more ${another} blah
/* ${you} */ ${yeah}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}