package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(--.*$|\/\*[\s\S]*?\*\/)`)
var str = `-- fdf
fdf
sdfdsf /* fsdf /* */ other /* */ sdfsdf
isdf -- sdf
/* fd */
/*
multiline
*/
more here
/* dangling
-- ${here} more ${another} blah
/* ${you} */ ${yeah}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}