# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z\-0-9\-\0-9]{1,})/PFK-720086-03/g;t' <<< "PFK-720086-03"