use strict;
my $str = 'PFK-720086-03';
my $regex = qr/([A-Z\-0-9\-\0-9]{1,})/p;
my $subst = 'PFK-720086-03';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";