// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z\-0-9\-\0-9]{1,})").unwrap();
let string = "PFK-720086-03";
let substitution = "PFK-720086-03";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}