const regex = /When: ([\w]{3}) ([\w]{3}) ([\d]{1,2}), ([\d]{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('When: ([\\w]{3}) ([\\w]{3}) ([\\d]{1,2}), ([\\d]{4})', '')
const str = `When: Mon Oct 27, 2013 to Fri Nov 1, 2013
<br />
<br />Event Status: confirmed</content>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}