re = /(?<Building>\b\d+)\s(?<Street>.*(?:#\d+|No Unit Number))\s(?<City>\b.+),\s(?<State>.{2})\s(?<Zip>\d{5}\b)/m
str = '1234 Street Name Unit #225 Harpers Ferry, VA 12345
5547 No Unit Number Jackson Hole, WY 12345
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end