// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<Building>\b\d+)\s(?<Street>.*(?:#\d+|No Unit Number))\s(?<City>\b.+),\s(?<State>.{2})\s(?<Zip>\d{5}\b)").unwrap();
let string = "1234 Street Name Unit #225 Harpers Ferry, VA 12345
5547 No Unit Number Jackson Hole, WY 12345
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}