Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?=\{((?:[^{}]++|\{(?1)\})++)\})
/
Input 1
1
New
hello hello - helleo ba blab blab alb { "collection1": [ { "property1": { "text": "O.P.\nA few forum post ads.\nThanks.", "href": "bla" }, "property2": "posted 2010-Jul-26, 1:21 am" }, ] } hello2 hello2 - helleo2 ba blab blab alb { "collection2": [ { "property1": { "text": "O.P.\nA few forum post ads2.\nThanks.", "href": "bla" }, "property2": "posted 2010-Jul-26, 1:22 am" }, ] }