# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([a-z\.-]+@)([a-z\.-]+)\b"
test_str = ("Please contact us at: support@github.com. \n"
"Just send email to s.miller@mit.edu and j.hopking@york.ac.uk for more information. \n"
"Many users @ SoftUni confuse email addresses. We @ Softuni.BG provide high-quality training @ home or @ class. –- steve.parker@softuni.de. \n\n"
"info@softuni-bulgaria.org\n"
"kiki@hotmail.co.uk\n"
"no-reply@github.com\n"
"s.peterson@mail.uu.net\n"
"info-bg@software-university.software.academy\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.